Anúncio

Algoritmo - Armazenar números pares entre 0 e 100 digitados

Faça um algoritmo capaz de armazenar os números pares entre zero e cem e dizer, qualquer que seja o número, se ele é par, ímpar ou zero, lembre-se que no final quero saber somente os números pares entre zero e cem digitados.
____________________________________________________________________________

algoritmo "semnome"
// Função :
// Autor :
// Data : 24/07/2013
// Seção de Declarações
var
RESULTADO: inteiro
NUMERO: inteiro
NUMEROS: vetor[1..5] de inteiro
POSICAO: inteiro
inicio
// Seção de Comandos
POSICAO := 1

ENQUANTO POSICAO <= 4 faca
   escreva ("Digite um número: ")
   leia (NUMERO)

      se NUMERO = 0 entao
         POSICAO := POSICAO + 1
         escreval ("Este número é zero")

      senao
         se NUMERO MOD 2 = 0  entao
            NUMEROS[POSICAO] := NUMERO
            POSICAO := POSICAO + 1
            escreval ("Este número é par")
         senao
            POSICAO := POSICAO + 1
            escreval ("Este número é ímpar")
         fimse
      fimse

FIMENQUANTO

POSICAO := 1
escreval ("Os números pares entre 0 e 100 por você digitados são: ")
enquanto POSICAO <= 5 faca
   se (NUMEROS[POSICAO] = 0) ou (NUMEROS[POSICAO] > 100) entao
      POSICAO := POSICAO + 1
      escreva ("")
   senao
      escreva (NUMEROS[POSICAO],",")
      POSICAO := POSICAO + 1
   fimse
fimenquanto

fimalgoritmo

Comentários
0 Comentários
Created By Sora Templates