Anúncio

Algoritmo - Armazenar os números compreendidos entre 0 e 100 e dizer se é ímpar ou par

Crie um algoritmo capaz de armazenar os números digitados entre 0 e 100 e dizer se o número é ímpar ou par, quando o número for 0, dizer que "O número digitado é zero".
_____________________________________________________________________

algoritmo "semnome"
// Função :
// Autor :
// Data : 22/07/2013
// Seção de Declarações
var
NUMEROS: vetor[1..6]de REAL
NUMERO: REAL
RESULTADO: REAL
POSICAO: REAL

inicio

POSICAO := 0
enquanto POSICAO < 6 faca
         escreva ("Escreva um número: ")
         leia (NUMERO)

              se (NUMERO = 0) ENTAO
                 escreva ("Este número é zero")

                           senao RESULTADO := NUMERO/2
                           se RESULTADO = 0   ENTAO
                           escreva ("Este número é par")
                           POSICAO := POSICAO + 1
                           senao escreva ("Este número é ímpar")
                           POSICAO := POSICAO + 1
               fimse
POSICAO := POSICAO + 1
fimalgoritmo
FIMSE

Comentários
0 Comentários
Created By Sora Templates