Anúncio

Algoritmo - Leia dois nomes e veja sua existência em um vetor com 50 nomes

Faça um pseudocódigo que leia dois nomes e veja se ele existe em um vetor com 50 nomes.
Obs.: Assim para gerar números, eu obriguei o código a gerá-los, para os nomes fiz a mesma coisa, usei 19 nomes femininos e mandei os seguintes (a partir do 20) a pegar um nome e somar com outro, como: "Maria", "Eduarda", "Gabriela"..., "Maria Eduarda", "Eduarda Gabriela"....
_______________________________________________________________________________

algoritmo "semnome"
// Função :
// Autor :
// Data : 25/07/2013
// Seção de Declarações
var
NOMES: vetor[1..50] de literal
POSICAO: inteiro
NOME: literal
CONTI: inteiro

inicio
// Seção de Comandos
NOMES[1] := "Maria"
NOMES[2] := "Júlia"
NOMES[3] := "Sophia"
NOMES[4] := "Isabella"
NOMES[5] := "Eduarda"
NOMES[6] := "Manuela"
NOMES[7] := "Giovanna"
NOMES[8] := "Alice"
NOMES[9] := "Laura"
NOMES[10] := "Beatriz"
NOMES[11] := "Bruna"
NOMES[12] := "Carolina"
NOMES[13] := "Lara"
NOMES[14] := "Renata"
NOMES[15] := "Yasmin"
NOMES[16] := "Amanda"
NOMES[17] := "Camila"
NOMES[18] := "Ana"
NOMES[19] := "Francine"

CONTI := 1
POSICAO := 20
enquanto POSICAO <> 51 faca
   NOMES[POSICAO] := NOMES[CONTI + 1] + " " + NOMES[CONTI]
   POSICAO := POSICAO + 1
   CONTI := CONTI + 1

   se CONTI > 18 entao
      CONTI := 2
   senao CONTI := CONTI
   fimse
fimenquanto

POSICAO := 0
Escreva ("Digite um nome para procurar: ")
leia (NOME)
enquanto POSICAO < 50 faca
   POSICAO := POSICAO + 1
   se NOME = NOMES[POSICAO] entao

      escreval ("Este nome encontra-se no cadastro, está na ",POSICAO,"° colocação.")
      POSICAO := 100

   fimse
fimenquanto
se POSICAO <> 100 entao
   escreva ("Este nome não pôde ser encontrado! :(")
fimse

POSICAO := 0
Escreva ("Digite um segundo nome para procurar: ")
leia (NOME)
enquanto POSICAO < 50 faca
   POSICAO := POSICAO + 1
   se NOME = NOMES[POSICAO] entao

      escreval ("Este segundo nome encontra-se no cadastro, está na ",POSICAO,"° colocação.")
      POSICAO := 100

   fimse
fimenquanto
se POSICAO <> 100 entao
   escreva ("Este segundo nome não pôde ser encontrado! :(")
fimse

fimalgoritmo

Comentários
0 Comentários
Created By Sora Templates