Anúncio

Algoritmo - Ler número e ver sua existência no vetor de 100 números

Crie um pseudocódigo que leia um número e diga se ele existe em um vetor com 100 números.
Obs.: Neste pseudocódigo, obriguei ele a gerar 100 números no vetor a partir do 360, sendo então que o primeiro número é 361, o segundo é 362 e assim por diante.
___________________________________________________________________

algoritmo "semnome"
// Função :
// Autor :
// Data : 24/07/2013
// Seção de Declarações
var
RESULTADO: inteiro
NUMERO: inteiro
NUMEROS: vetor[0..100] de inteiro
POSICAO: inteiro

inicio
// Seção de Comandos
POSICAO := 1
enquanto POSICAO <= 100 faca
   NUMEROS[POSICAO] := (POSICAO + 360)
   POSICAO := POSICAO + 1
fimenquanto



POSICAO := 0
escreva ("Digite um determinado número: ")
leia (NUMERO)
enquanto POSICAO < 100 faca
   POSICAO := POSICAO + 1
   se NUMERO =  NUMEROS[POSICAO] entao

      escreval ("Este número foi encontrado e ele existe, encontra-se na colocação", (POSICAO))


   FIMSE
FIMENQUANTO

se NUMERO > POSICAO + 360 entao
   ESCREVAL ("Este número não foi encontrado")

FIMSE

fimalgoritmo




Comentários
0 Comentários
Created By Sora Templates