Anúncio

Algoritmo - Matriz que armazene o nome de dois alunos e diga a média de suas notas

Crie um algoritmo com matriz capaz de armazenar dois nomes de dois alunos e duas notas de cada, no final quero saber a média das notas de cada aluno.
Obs.: É necessário usar uma matriz para nome dos alunos como : literal e uma para notas : numerico para que possa somar e dividir as notas por dois e obter a média.
______________________________________________________________________

algoritmo "semnome"
// Função :
// Autor :
// Data : 26/07/2013
// Seção de Declarações
var
CONTADOR1, CONTADOR2: inteiro
MATRIZ: vetor [1..1,1..2] de literal
NOTAS: vetor [1..2,1..2] de numerico
MEDIA1,MEDIA2: numerico
inicio
// Seção de Comandos
CONTADOR1:= 1
CONTADOR2:= 1
enquanto (CONTADOR2 <= 2) e (CONTADOR1 <= 2) faca
   escreva ("Digite o nome do ",CONTADOR2,"º aluno(a): ")
   leia (MATRIZ[CONTADOR1,CONTADOR2])
         escreva ("Digite a PRIMEIRA nota do(a)",CONTADOR2,"º aluno(a): ")
         leia (NOTAS[CONTADOR1, CONTADOR2])
         CONTADOR1 := CONTADOR1 + 1
         escreva ("Digite a SEGUNDA nota do(a)",CONTADOR2,"º aluno(a): ")
         leia (NOTAS[CONTADOR1, CONTADOR2])
         CONTADOR2 := CONTADOR2 + 1
         CONTADOR1 := 1
fimenquanto
MEDIA1:= (NOTAS[1,1] + NOTAS[2,1]) / 2
MEDIA2:= (NOTAS[1,2] + NOTAS[2,2])/ 2
escreval ("A média do aluno(a) ",MATRIZ[1,1]," é ",MEDIA1,".")
escreval ("A média do aluno(a) ",MATRIZ[1,2]," é ",MEDIA2,".")
fimalgoritmo
Comentários
1 Comentários
Created By Sora Templates