Anúncio

Algoritmo - Tempo da volta do velocista

Crie um algoritmo que armazena o tempo das 50 voltas que o velocista faz, no final, mostre a volta que teve o menor tempo.
___________________________________________________________________________

algoritmo "semnome"
// Função :
// Autor :
// Data : 22/07/2013
// Seção de Declarações
var
VOLTAS: vetor[1..5]de literal
TEMPO: literal
MENOR: literal
POSICAO: inteiro

inicio

POSICAO := 0
enquanto POSICAO < 5 faca
   escreva ("Escreva o tempo da ",(POSICAO + 1),"ª volta: ")
   leia (TEMPO)
   se POSICAO = 0 entao
      MENOR := TEMPO
   fimse
   se (TEMPO < MENOR) ENTAO
      MENOR := (TEMPO)
   fimse
   POSICAO := POSICAO + 1
   VOLTAS[POSICAO]:= TEMPO
fimenquanto
POSICAO := 0
enquanto POSICAO < 5 faca
   POSICAO := POSICAO + 1
   escreval ("Na volta",(POSICAO)," você correu em ",(VOLTAS[POSICAO])," minutos.")

fimenquanto


ESCREVAl ("O seu menor tempo foi ",(MENOR)," minutos.")

fimalgoritmo

Comentários
0 Comentários
Created By Sora Templates